
Data capture and analysis with Engduino and spreadsheets

Engduino Support Team - support@engduino.org University College London

1. Introduction

In this tutorial we are going to get an idea of how to capture data from the Engduino, in particular the
accelerometer, and then perform some analysis of the data. There are many situations when you may
want to collect data from an external device and then use a computer to analyse it. For example, civil
engineers sometimes place devices that count vehicles and record the times they go past so that they can
make decisions on how many lanes a road needs, whether it’s a good idea to restrict parking, or optimise
traffic light timings.

1.1. Aims

What we want to be able to do is collect data from the accelerometer and then save it to a special file
that we can open in a spreadsheet. Once this is done we may analyse the information more easily so that
we might draw conclusions. We will connect the Engduino and get a friend to perform a movement of
some sort: running on the spot, marching on the spot, jumping in the air, or perhaps a combination of
these movements. We must ensure we are unable to see them performing the movement so that we can
figure out what the person did based on analyses of the data.

1.2. Equipment Needed

For this you will need:

• Engduino and a long USB extension cable.
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• The python app to receive the data and any computer/Raspberry Pi that has a python environment
installed. See python.org if you need to install it on your Windows machine.

• MS Excel or OpenOffice Calc.

• A friend

2. Preparation

Download the python ”AccelerometerCaptha.py” app from our website (click here if you haven’t down-
loaded it yet) and drop it on your desktop or somewhere it can easily be found. Download the SerialAc-
celerometer.ino from our website (click here) and upload it to your Engduino device. Refer to here if
you are unsure how to do this. IMPORTANT: You need to install pyserial to communicate with the
device. See here for instructions on how to do this.

3. A little background information

In order to understand what you are doing a little more, we are going to quickly talk about the accelerom-
eters so we know a little bit about the data before we try to analyse it.

3.1. Accelerometers

3.1.1 What is an accelerometer?

An accelerometer is an electromechanical device that will measure acceleration forces. These forces may
be static, like the constant force of gravity pulling at your feet, or they could be dynamic - caused by
moving or vibrating the accelerometer. By measuring the amount of static acceleration due to gravity,
you can find out the angle the device is tilted at with respect to the earth. By sensing the amount of
dynamic acceleration, you can analyse the way the device is moving.[1]

3.1.2 How does the accelerometer measure gravity

An accelerometer measures the force being applied on it in three different dimensions, X, Y, and Z.
Using these three dimensions and a little knowledge about vectors we can work out the acceleration in
any direction in 3-dimensional space. The accelerometer on the Engduino provides these values in g .
One g is equal to ≈ 9.8m.s−2 which is the force due to acceleration that is constantly being applied to
us whilst standing on the earth’s surface. 2 g would be twice that number or ≈ 19.6m.s−2.
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Figure 1: How the XYZ axes look to us

3.1.3 Important points

What is important to remember from all this is that your Engduino will always have a total vector force
of 1g on it when it is at rest, like lying on a table. If we see any changes, it means something is making
it move or change direction. Conversely, if it is moving at a constant velocity (speed) and not changing
direction, the accelerometer will only detect the force due to gravity, i.e. the accelerometer cannot tell
you when it is moving, only when it is changing direction or speed or being moved from rest.

4. Getting the data

Let’s make sure everything is working. Once you’ve uploaded the SerialAccelerometer.ino to your
Engduino and you’re sure it’s switched on, in the Arduino IDE: click on the serial monitor button as
shown.
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Figure 2: Activating the serial monitor

You should see a small window pop up and the Accelerometer data scrolling through in sets of three.
Like this
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Figure 3: The Arduino serial monitor

If you move the board around, you should see these values change. If that’s all working, you are ready to
start. Start up the AccelerometerCaptcha.py on your computer by double-clicking the file. You should
see a window like this if you are on Windows

Figure 4: The Python Data Logger

(on Mac or Linux it will slightly different). Double check in the Arduino IDE what port number is
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selected for your board by selecting Tools→Board and seeing which one is checked. In the Data Capture
window select the Device menu and then choose the ”Select your Device” option. In Windows, a popup
window will appear and ask you for the COM port number. Enter it here, without the COM bit, so
if your COM port is COM5 you would enter just 5. Once that’s done, test the logger to see that it’s
communicating with the board. Hit the start button on the bottom.

Figure 5: Start loggin

The window in the centre of the program should show the values you saw in the Arduino Serial Monitor.
If not, re-check the port number is correct and that the device is switched on.

5. Capturing your Friend’s movement

Once you’re all set up get your friend to hold the device in their hand (make sure you are using the
extension cable) and tell them to hit start once you cannot see what they are doing. You can turn around
or leave the room. Ask them to keep an eye on the window and keep moving until the message ”Log
Complete” appears.

6. Saving the data

The data has now been temporarily saved into a file called accell.csv. By clicking the Save button you
can save it somewhere it can easily be found.

7. Importing the data

We now need to import the data into Excel. The procedure for OpenOffice versions is the pretty much
the same, you can get in touch with us if you have any problems. Once you’ve opened Excel, click File
→ Open and select the file you just saved. Your file should be populated with three columns like this.
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Figure 6: Imported Data

8. Analysing the Data

If you look at the numbers in the column you will see they are somewhere in the range of −2 → 2.
These represent how many g is being detected on each axis. The first column is the X axis, the second
is Y and the third, Z. Looking at this each row is the values extracted at 1
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th of a second intervals.

8.1. Getting the absolute value of the acceleration vector

When we add the three vectors we get a final vector in 3D space that represents the total acceleration.
Like this:

Figure 7: Total vector(black) in 3D space
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However, trying to see how this changes over time is difficult since one of these diagrams would have to
be made for every row! Let’s see if we can make it easier.

8.2. Vector magnitude

We could probably work out what was happening with the device if we just looked at the magnitude of
the vector instead of worrying about it’s direction too. If you think about it, your friend probably won’t
rotate the device much in their hand while they’re is jumping around. So what we are most interested
in is just the magnitude. We expect the total magnitude, when they are standing still with the device, to
be around 1g (remember that’s how much force gravity exerts on us when we are stood still). If they
jump, we might expect there to be a brief moment of strong acceleration as they pushes themselves off
the floor and then perhaps when they land there will be another. So we should see a much larger total
magnitude at these times. Perhaps by looking at these spikes graphically and comparing them to one
another we can try and get a picture of what our friend did.

9. Preparing the data

To get the magnitude of a vector we need to use Pythagoras’ theorem a little. In 2D space we get the
magnitude of a vector by calculating

magnitude =
√
X2 + Y 2 (1)

Just like when we are calculating the size of the hypotenuse of a triangle by using the adjacent sides.
What you may not know is this also works in three dimensions. So to calculate the total magnitude of
all three vectors we simply take the square root of the sum of the squares.

magnitude =
√
X2 + Y 2 + Z2 (2)

Let’s get Excel to calculate this value for us and put it in a column next to our values so we can use it
later.

9.1. Excel Formula

First select the top cell to the right of the Z value like so:

Now, type the following =SQRT(A1*A1+B1*B1+C1*C1). Don’t forget the ”=” sign!

This tells excel you want it to calculate a value. The values A1, B1 and C1 are cells and if you look
carefully you should be able to see they correspond to the values to the left of the square. It will
multiply (*) each value by itself, then add them up (using the + symbol) and then the function SQRT
will substitute the square root of that calculation into the box. When you hit return, you should see
a number in the box. Probably around 1, if your friend was standing still when they first pressed the
”Start” button on the program window.

9.2. Copying the formula

We obviously don’t want to have to keep typing this whole formula for every single line so luckily, Excel
has a nifty trick. Make sure you have the box you just typed in selected. If you bring your mouse to the
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bottom right corner of the box you will see a small dot, when you hover over this dot, your cursor will
change to a small black cross like this

Figure 8: Selecting

Now click and drag the little dot all the way to the last row of the data. Your window will automatically
scroll down when you get to the bottom so don’t let go until you’re at the end! When you let go you
should see the values populating down your new column, similar to this

Figure 9: Copying the formula
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This column now contains our total magnitude for each sample, but we can get rid of the extra precision.
Two decimal places should be plenty. Highlight all the cells by dragging your cursor over them and then
click the reduce decimal places button until you have just two decimal places per row. Great, let’s graph
it and see if we can make some sense of it.

Figure 10: Reducing decimal places

10. Graphical analysis

Highlight all the values in the last column and then Insert → Line Chart. Excel will create a chart that
shows something like this (if your friend did their job correctly!)

Figure 11: Graph of magnitude over time
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So lets take a look at our graph. Make it as big as your screen will allow by dragging the bottom right or
top right corner of the containing box so we can see what’s happening. On the bottom axis we see the
sample number. Remember, each sample is taken at 1
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th of a second, so every 5 samples is one second of
time. The vertical axis shows us the magnitude. As you can see, just after our friend pressed the ”Start”
button to begin logging he was still stood still and so our graph shows a total magnitude of 1g. Then
later on at some point, the acceleration went all the way past 2g. Let’s zoom in on this area of interest
for a moment.

Figure 12: Zoomed in on the area of interest

I’ve indicated this first event with the red arrows. So at some point the magnitude of the acceleration
went all the way past 2g and then went all the way down to almost 0, then a short time after that went
back up to 2 and then settled near 1 for a while. What do you think this could mean?
Think about it for a moment.
Keep this picture of the different stages of a human jump in mind for reference.
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Figure 13: Stages of a human jumping over time

When we first bend down getting ready to jump, we move with gravity a little, so the force on us is
slightly lower. This explains the first tiny dip.

Figure 14:
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Then we push off with our legs we create a strong force of acceleration. This explains the first spike.

Figure 15: Jump

As we near the top of a jump, for an instant we are stationary, so the value of the acceleration goes to...?
Well done if you said 1! Remember when we are stationary on the earth’s surface, or the air, gravity
exerts a force of 1g on us. So it goes to 1 here.

Figure 16: Stationary in the air

But, it doesn’t stop going down because as soon as we’re stationary we start moving back down towards
the ground. In free fall we are moving almost entirely with the force of gravity, so our accelerometer
registers a total magnitude of nearly 0.
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Figure 17: Free-falling to ground

Once we hit the ground, there is a sharp and strong acceleration that stops us from moving (from the
ground) and then it settles back to 1 for some time while we are stood still. In my example you can see
5 similar patterns except they start becoming smaller. So, maybe my friend jumped high the first time,
then jumped as soon as he hit the ground again, then he rested for a moment and did another two jumps
and then moved only slightly and then did a little jump. What did your friend do? Ask them, and see
how well you did.

11. Your own experiment

To get an idea of how different movements appear on your graph, get your friend to first take two steps
on the spot. Then wait a second, and do a small jump, and then wait a few seconds and do a jump as
high as he can. Follow the steps above and create your graph in a new file. Keep this file open and use
it as a reference when you analyse some movements you didn’t see. Swap positions and see how your
friend compares to you.
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11. References

[1] A beginners guide to accelerometers, http://www.dimensionengineering.com/info/accelerometers.
Dimension Engineering LLC
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